RSS   Twitter   Copiny   Copiny
Нашел ошибку? 

Выдели фрагмент текста с ошибкой или неточностью и нажми Ctrl+Enter!

Стоит ли переходить на Joomla 3?

Ответы на основные вопросы по новой версии Joomla

Стоит ли переходить на Joomla 3?

После выхода новой версии Joomla, многие задумываются, а нужно ли переходить на новую версию, и если да, то когда.

Ответы на эти и многие другие вопросы вы найдете в этом небольшом FAQ по Joomla 3.

Что нового в Joomla 3? Чем отличается от Joomla 2.5?

Самое серьезное нововведение — это совершенно новый дизайн панели управления, он работает на Twitter Bootstrap + jQuery. В результате он стал более простым и удобным. Появилась поддержка адаптивной верстки, т. е. внешний вид будет подстраиваться под мобильные устройства.

Разработчики расширений так же получили новые вкусности, например, свежий Joomla Framework, новый установщик расширений, нативную поддержку jQuery.

Сколько времени каждая версия будет поддерживаться?

Крупные релизы Joomla поддерживаются в течение 3-х лет. При их обновлении не должно быть никаких сложностей.

Joomla 2.x серии (которые включали 1.6 и 1.7 из-за конфликта имен) имеют поддержку в течение 3х лет (с января 2011 по весну 2014 года). С версий Joomla 1.6 по 1.7 и с 1.7 по 2.5 было обновление в один клик. А версия 2.5 будет поддерживаться до весны 2014 года. Таким образом 2.x версии имеют поддержку более трех лет и в целом это поможет плавно перейти на новые версии пользователям и разработчикам расширений.

Версии 3.x также будут поддерживаться около трех лет. Обновления с 3.0 до 3.1 и до 3.5 будет производиться в один клик.

Я собираюсь сделать новый сайт. Лучше использовать Joomla 2.5 или Joomla 3.0?

Начните с 2.5, если вы хотите большой стабильности CMS и/или если вы собираетесь использовать много сторонних расширений.

Разрабатывайте сайт на 3.0, если все расширения, которые вы собираетесь использовать, совместимы с этой версией.

На данный момент только некоторые шаблоны и расширения совместимы с Joomla 3.0, а большинство из них будут готовы спустя только несколько месяцев после выпуска версии.

Как я могу получить совместимые с Joomla 3.x шаблоны?

Некоторые разработчики подготовили шаблоны почти сразу после выпуска новой версии. Кроме того, обратите внимание, что есть и 2.5 шаблоны совместимые с 3.0. Но лучше всего проконсультироваться с разработчиками о совместимости по каждому отдельному шаблону.

Будут ли мои Joomla 2.5 расширения работать на версии 3.0?

Расширения, которые являются родными для Joomla 2.5, будут работать и с 3.0 с очень небольшими изменениями, если таковые вообще понадобятся. Компоненты и шаблоны будут менее всего адаптированы под Joomla 3.0, в то время как модули и плагины должны работать без проблем (при условии, что они не используют устаревшие функции). Компоненты, которые поддерживают одновременно Joomla 1.5 и 2.5, скорее всего не заработают, пока их не обновят разработчики.

В общем, это зависит от самих расширений. Разработчики Joomla CMS сделали процесс относительно легким для большинства из них, однако для перехода некоторых потребуется немного попотеть. Для убедительности, проконсультируйтесь сначала с разработчиками расширений или ознакомьтесь с документацией о совместимости с 3.x.

Что делать, если я хочу установить Joomla 3.x сайт, но расширение я хотел(а) бы использовать, которое написано под 2.5?

Вам необходимо спросить у разработчиков расширения, собираются ли они в ближайшем будущем делать поддержку 3.0. Разработчикам может потребоваться доработать расширение, но насколько серьезно зависит от самого расширения.

Стоит ли мне обновлять сайт с Joomla с 2.5 до 3.0?

В большинстве случаев — нет. Поддержка Joomla 2.5 будет продолжаться до весны 2014 года и вы можете обновить тогда, когда версия будет хорошо протестирована пользователями. Вы даже можете подождать до версии Joomla 3.5, которая будет выпущена примерно через год после выпуска 3.0 и в ней будет содержаться прямое обновление.

Обновлять стоит, если вы желаете использовать новые возможности, доступные только в 3.x или быть впереди планеты всей:)

У меня есть сайт на Joomla 2.5. Менеджер обновлений позволяет мне обновить до версии 3.0. Я должен это сделать поскольку он мне позволил?

Нет, пока вы не уверены на 1000% (не меньше 10 раз все перепроверьте), что обновление произойдет успешно. По умолчанию, Joomla не даст обновить себя до версии 3.0. Только если вы не активировали опцию внутри компонента обновления Joomla (administrator >> Component >> Joomla! Update >> Options >> Update server >> Short Term Support). Если по некоторым причинам вы изменили эту опцию, но хотите, чтобы компонент перестал обновлять, измените настройку на «Long Term Support». После этого вы будете получать обновления только для Joomla 2.5.

Примечание: вы не должны обновлять версию с 2.5 на 3.0, пока не будете полностью уверены, что ваши установленные расширения (от сторонних разработчиков), особенно шаблоны, совместимы с Joomla 3.0 или по крайней мере имеют версию для 3.0, чтобы их тоже можно было обновить.

Что будет после Joomla 3.0?

Через несколько месяцев появится Joomla 3.1. Не волнуйтесь, хотя бы потому что обновление будет обратно совместимым и производиться в один клик. Если вы к тому времени начнете использовать Joomla 3.0, то рекомендуем вам как можно скорее обновлять ее до 3.1. Если вы все еще будете использовать Joomla 2.5, то вы можете подождать выхода Joomla 3.5 и получить прямое обновление сразу с 2.5 на 3.5.

Хорошо. Я готов и хочу обновить свой сайт. Как я могу это сделать?

  1. Ознакомьтесь с системными требованиями для Joomla 3.0 и удостоверьтесь, что ваше серверное ПО поддерживает эти требования.
  2. Удостоверьтесь, что все ваши расширения (особенно ваш шаблон) совместимы с Joomla 3.0.
  3. Создайте копию вашего сайта на тестовом сервере (например, Денвере) и попробуйте его обновить.
  4. Проконсультируйтесь с опытными разработчиками, если вы ни в чем не уверены на 120%.
  5. Сделайте полную резервную копию вашего сайта (файлы и база данных).

Как только это все готово, перейдите в компонент обновлений Joomla. Кликните на опцию и измените, чтобы установить режим в «short term support». Сохраните. Вы должны быть уведомлены о наличии Joomla 3.0. Кликните на кнопку установки. Очистите кэш браузера и убедитесь, что изменения вступили в силу. Это все!

В заключение, несколько раз проверьте, что все работает должным образом.

Примечание: на некоторых хостингах может потребоваться использование альтернативных методов обновления, таких как установщик расширений.

Но что, если я на Joomla 1.5? Мой сайт сломается? Переходить мне на 2.5 или 3.0?

Поддержка Joomla 1.5 официально окончена (!).

Означает ли это, что ваш сайт на 1.5 перестанет работать?

Нет, ваш сайт будет продолжать работать так, как это всегда было. Тем не менее, подавляющее большинство разработчиков уже перестало выпускать новые версии своих расширений для Joomla 1.5. Таким образом вы не сможете получать исправления багов и улучшения по безопасности. Если для вас это критично, мы рекомендуем обновить версию 1.5. до 2.5 или 3.0

Переход с 2.5 на 3.0 относительно прост, т. к. Joomla упростила процесс для более новых версий. Но к сожалению, переезд с 1.5 — далеко не тривиальная задача. К счастью, есть 2 хороших расширения, делающих процесс проще: jUpgrade и SP Upgrade.

Вы можете выбрать, перейти вам сразу на 3.0 или сначала на 2.5. Оба расширения jUpgrade и SP Upgrade имеют версии для этих двух случаев. Прежде чем использовать их, пожалуйста проконсультируйтесь с их документацией о том, как переезжать с Joomla 1.5 на 3.0/2.5.

Выводы?

Переезжайте на 3.0, если все необходимые для вас расширения совместимы с ней.

Переходите на 2.5, если вы хотите иметь более стабильную версию Joomla или собираетесь использовать большое количество расширений.

Смотрите также:
Комментарии (10) Добавить комментарий
  • Mirotvoretz
    Mirotvoretz
    19 Января 2013, 16:35
     ↑  +2  ↓     ответ

    Подскажите, если из стронних расширений на сайте используется только zoo и jbzoo, имеет ли смысл делать сайт уже на 3.0 или всё-таки на 2.5? В новой версии очень привлекает адаптация к мобильным устройствам.

    • smet.denis
      smet.denis (админ)
      19 Января 2013, 17:05
       ↑  +2  ↓     ответ

      Zoo и JBZoo хорошо работают с Joomla 3.x. Думаю вам ничего не должно помешать.

      В будущем всё равно все разработчики расширений рано или поздно перейдут на Joomla 3.

  • Андрей
    Андрей
    20 Февраля 2013, 16:16
     ↑  +3  ↓     ответ

    Решил обновить один из своих сайтов до Joomla 3.1, с 2.5. Все расширения совместимы. Выставил в настройке обновлений расширения с краткосрочной поддержкой, пишет, у вас уже последняя версия. На самом деле версия 2.5.8, даже не хочет обновляться до 2.5.9. На некоторых сайтах обновление до 2.5.9. прошло, на других еще 2.5.7 не обновляется, при настройке долговременная поддержка. Менял настройки - все равно не обновляется. Есть ли другие способы обновить Joomla до 3.1?

    • Василий
      Василий
      05 Июня 2014, 19:50
       ↑  0  ↓     ответ

      Нужно почистить кеш раширения-менеджер расширений-обновления

  • Дмитрий
    Дмитрий
    26 Апреля 2013, 00:15
     ↑  0  ↓     ответ

    Подскажите, у меня сайт на joomla 3.0, когда выйдет joomla 3.1 и потом joomla 3.5, я смогу обновить сайт до этих версий и при этом не повредив шаблон и расширения ? На данный момент на моем сайте установлен шаблон который подходит для Joomla 3.0, не испортится ли он после обновления joomla до версии 3.1 и потом до других версий ? и не испортятся ли расширения для joomla 3.0 когда я обновлю её до более высоких версий ?

    • smet.denis
      smet.denis (админ)
      26 Апреля 2013, 13:53
       ↑  0  ↓     ответ

      Скорее всего можно будет обновится аккуратно до новой версии, вплоть до 3.5

      Сообщество Joomla.org пытается сделать версии как можно более схожие между собой с точки зрения API.

  • Инна
    Инна
    16 Октября 2013, 20:06
     ↑  +1  ↓     ответ

    Просьба уточнить...

    Как происходит обновление шаблона при переходе на более свежую версию (индивидуальный дизайн).

    Сейчас сайт на Joomla 2.5. Насколько сильно нужно будет производить модернизацию сайта?

  • Joomla Web
    Joomla Web
    27 Сентября 2014, 14:30
     ↑  -1  ↓     ответ

    Ну думаю что теперь, когда разработчики четко сказали что Joomla 2.5.* развивать с начала 2015 года не будут, вопрос о переходе на joomla 3.3 становится более актуальным ....

  • Ref
    Ref
    14 Января 2015, 23:55
     ↑  +1  ↓     ответ

    В разница шаблонов 1.5 и 3.0? Насколько сложно адаптировать старый шаблон к новым требованиям джумлы?

  • Виктор
    Виктор
    06 Ноября 2015, 20:36
     ↑  0  ↓     ответ

    Дизайн "стал более простым и удобным" та х*р там. По прежнему оставили в админке это дебильное неактивное меню; все иконки за которые "цеплялся глаз" (версия 2,5) заменили, банально, текстом.

    Адаптивная вёрстка - кривая (смотрим страницу конфигураций).

Оставить комментарий




* обязательно для заполнения

1 введенный почтовый адрес используется только для обратной связи при ответах в комментариях и сервиса gravatar.com
.